4g61t.org

Specializing in the 3g CSM
It is currently Sat Jul 20, 2019 6:42 am

All times are UTC-05:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Fri May 02, 2014 8:13 am 
Offline
Member

Joined: Fri May 02, 2014 7:28 am
Posts: 86
Location: Philippines
I'm in The Philippines but everything should technically still match... I have a 1991 Mitsubishi Lancer GTI which is a C62A with a 4G15 SOHC, EFI, N/A.

The check engine light turned on and off multiple times and after awhile it finally stayed on. I've reset the computer and replicated it.

I reset once again and this time I checked the error codes. The first one is Code 14 "Throttle position sensor (TPS) fault." then after a few minutes of Idle and revving I get Code 14 and Code 15 "Idle speed control (ISC) motor position sensor fault."

I've already asked the peeps in our local Mitsubishi Lancer car club and they said to replace the sensors and the servo, but the problem is it's extremely hard to find the Idle Speed Servo and Sensor. My question is can you repair and/or clean the sensors and servo?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC-05:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited