4g61t.org

Specializing in the 3g CSM
It is currently Tue Sep 25, 2018 9:57 pm

All times are UTC-05:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue Aug 29, 2017 9:11 am 
Offline
Member
User avatar

Joined: Tue May 05, 2009 11:58 pm
Posts: 79
Location: Belpre, Ohio
Was tinkering around and noticed my Expo is missing something. Someone help me out please? I have 3 empty holes that look like they're threaded.

Image


Top
   
PostPosted: Tue Aug 29, 2017 6:49 pm 
Offline
Moderator
User avatar

Joined: Wed Jan 04, 2006 1:21 pm
Posts: 2094
Location: Tucson Az
if u take a flashlight and look in there it should be the screws to hold it up.. there should be covers that either pop in or screw in to fill the holes



Steve

_________________
Steve 89 colt 2.3 stroker stock top end. evo3@20 psi 13.489@99.30mph 3/10 2012
On drag radials.auto trans.launching @ 5 psi and no traction thru 2nd.


Top
   
PostPosted: Wed Aug 30, 2017 8:23 am 
Offline
Member
User avatar

Joined: Tue May 05, 2009 11:58 pm
Posts: 79
Location: Belpre, Ohio
Ahh, Thank you. I don't recall seeing any screws in there. I'll have to take a closer look when I get home.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC-05:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited